Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковые цифры, стоящие рядом (как, например, 221)
Желательно программу на Паскале
Ответы на вопрос
Ответил AnonimusPro
0
Program n1;
var a,temp: integer;
b: boolean;
begin
readln(a);
temp:=-a;
b:=false;
while a<>0 do
begin
if temp=(a mod 10) then begin
b:=true;
break;
end;
temp:= a mod 10;
a:=a div 10;
end;
if b then write('верно') else write('неверно');
end.
var a,temp: integer;
b: boolean;
begin
readln(a);
temp:=-a;
b:=false;
while a<>0 do
begin
if temp=(a mod 10) then begin
b:=true;
break;
end;
temp:= a mod 10;
a:=a div 10;
end;
if b then write('верно') else write('неверно');
end.
Новые вопросы
Алгебра,
2 года назад
Математика,
2 года назад
Математика,
8 лет назад
Обществознание,
8 лет назад
Литература,
9 лет назад