Напишите программу которая определяет находится ли введеный год в прошлом настоящем или будущем (работа в паскале
)
Ответы на вопрос
Ответил Аноним
2
Проблем быть не должно, думаю, это самое примитивное.
Program asd;
Var x: integer;
Begin
read(x);
if x<2017 then Write(' — ',x,' год уже прошел.') else
if x=2017 then Write(' — ',' Сейчас — ',x,'.') else
if x>2017 then Write(' — ',x,' Еще не настал.')
end.
Надеюсь, помог.
Буду благодарен, если выберешь "Лучший"
Удачи!
Program asd;
Var x: integer;
Begin
read(x);
if x<2017 then Write(' — ',x,' год уже прошел.') else
if x=2017 then Write(' — ',' Сейчас — ',x,'.') else
if x>2017 then Write(' — ',x,' Еще не настал.')
end.
Надеюсь, помог.
Буду благодарен, если выберешь "Лучший"
Удачи!
drobysh56:
Скажите почему ошибку выдает.. После бегин там с о знаками проблемки да
Ответил Aillianna
0
const current_year = 2017;
var year: integer;
begin
readLn(year);
if year < 2017 then
Write(year, ' прошлое')
else if year = 2017 then
Write(year, ' настоящее')
else if year > 2017 then
Write(year, ' будущее')
end.
var year: integer;
begin
readLn(year);
if year < 2017 then
Write(year, ' прошлое')
else if year = 2017 then
Write(year, ' настоящее')
else if year > 2017 then
Write(year, ' будущее')
end.
Новые вопросы
Математика,
1 год назад
Математика,
2 года назад