Информатика, вопрос задал dimakuharenok2008 , 2 года назад

Напишите программу, которая находит сумму квадратов чисел от 1 до N кратных 7. Значение переменной N ввести с клавиатуры.

7в квадрате+14 в квадрате +21 в квадрате+…+X в квадрате, где X<=N

Ответы на вопрос

Ответил fannywinston2020
1

Ответ:

s = int(input())

n = 0

x = 0

for i in range (1,s+1):

   if i %7==0:

       x = i**2

       n = n + x

print(n)

Объяснение:

Изначально вводишь значение, затем он создает цикл при этом проверяет все число до s на деление на 7, затем он складывает квадраты этих чисел!


dimakuharenok2008: Спасибо, но нужно в Pascal ABC
Новые вопросы