напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. Программа получает на вход це¬лые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: сумму двузначных нечётных чисел в последовательности.
Входные данные: 11, 15, 30, 9, 0
Выходные данные: 26.
Ответы на вопрос
Ответил Аноним
0
Решение фактически в один оператор
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadSeqIntegerWhile(n->n<>0)
.Where(n->n.IsOdd and (n>=10) and (n<=99)).Sum)
end.
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadSeqIntegerWhile(n->n<>0)
.Where(n->n.IsOdd and (n>=10) and (n<=99)).Sum)
end.
Ответил Аноним
0
Var
A:integer;
S:real;
Begin
S:=0;
Repeat
Read(A);
if (9<Abs(A))and(Abs(A)<100)and(A mod 2 <> 0) then S:=S+A;
Until A=0;
WriteLn(S)
End.
A:integer;
S:real;
Begin
S:=0;
Repeat
Read(A);
if (9<Abs(A))and(Abs(A)<100)and(A mod 2 <> 0) then S:=S+A;
Until A=0;
WriteLn(S)
End.
Новые вопросы
Физика,
2 года назад
Алгебра,
2 года назад
Физика,
8 лет назад
Математика,
8 лет назад
Биология,
9 лет назад