Информатика, вопрос задал mahmudovaalina39 , 2 года назад

напишите программу, которая находит сумму цифр целого числа, введённого с клавиатуры.
Помогите пожалуйста! ​

Ответы на вопрос

Ответил Аноним
0

Ответ:

n = int(input())

print(f'сумма цифр числа {n} =', end=' ')

s = 0

while n > 0:

   s += n % 10

   n //= 10

print(s)

Объяснение:

можно и так

n = input()

s = 0

for i in n:

   s += int(i)

print(f'сумма цифр числа {n} = {s}')

с проверкой на ввод можно так

n = input()

s = 0

for i in n:

   if n.isdigit():

       s += int(i)

   else:

       print('введено не число')

       break

else:

   print(f'сумма цифр числа {n} = {s}')


MaxLevs: А если введено не число?
Аноним: по условию вводится целое число, ничего про обработку ошибок не сказано
Ответил MaxLevs
0
  • def get_int_seq(s=""):
  •    while True:
  •        try:
  •            k = int(input(s))
  •        except ValueError:
  •            print("[Warning] Type int numbers please")
  •            continue
  •        if k == 0:
  •            break
  •        yield k
  •    return
  • def sum_of_numbers(x):
  •    if x == 0: return 0
  •    (xs, x) = divmod(x, 10)
  •    return x + sum_of_numbers(xs)
  • for k in get_int_seq():
  •    print("[%d] Sum of numbers: %d" % (k, sum_of_numbers(k)))
  • else:
  •    print("Exit!")
Приложения:
Новые вопросы