Информатика, вопрос задал renalbulatov0166 , 6 лет назад

Напишите программу, которая находит произведение, сумму, максимальное число всех элементов массива из диапазона [10,100], которые делятся на 3 и оканчиваются на 1. ​

Ответы на вопрос

Ответил daniyarkanu
1

Решение:

Python

spisok1 = []

spisok2 = []

spisok3 = []

for index in range(10, 101):

   spisok1.append(str(index))

for index in spisok1:

   if index[-1] == '1':

       spisok2.append(index)

spisok2 = list(map(lambda index: int(index), spisok2))

for index in spisok2:

   if index % 3 == 0:

       spisok3.append(index)

print(max(spisok3))

Новые вопросы