Напишите программу, которая находит квадрат произведения цифр
введенного числа
Ответы на вопрос
Ответил petyaGavrikov
0
var a,p:integer;
begin
write('a = ');
readln(a);
a:=abs(a);
p:=1;
while a<>0 do
begin
p:=p*(a mod 10);
a:=a div 10;
end;
p:=p*p;
writeln('p = ',p);
end.
Пример:
a = 273
p = 1764
begin
write('a = ');
readln(a);
a:=abs(a);
p:=1;
while a<>0 do
begin
p:=p*(a mod 10);
a:=a div 10;
end;
p:=p*p;
writeln('p = ',p);
end.
Пример:
a = 273
p = 1764
Новые вопросы