Напишите программу, которая находит частное (суммы всех четных чисел) / (Разность всех нечетных чисел), записанных в файле в столбик, и выводит результат в другой файл.
Ответы на вопрос
Ответил Аноним
0
#include <iostream>
using namespace std;
signed main() {
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
int x;
double sum = 0,dif = 0;
while(cin >> x){
if(x % 2 == 0)
sum += x;
else
dif -= x;
}
cout << sum/dif;
fclose (stdout);
}
GenaBukin00:
паскаль
Ответил BobbyFresnel
0
// PascalABC.NET
begin
var (se, so) := (0, 0);
foreach var s in ReadLines('input.txt') do
begin
var t := s.ToInteger;
if t.IsEven then
se += t
else
so += t
end;
WriteAllText('output.txt', (se / so).ToString)
end.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Математика,
2 года назад
Литература,
2 года назад