Информатика, вопрос задал РаскольниковРодион , 8 лет назад

Напишите программу, которая на вход получает целое число и проверяет, есть ли в числе 2 одинаковые цифры (pascal, с использованием циклов)

Ответы на вопрос

Ответил srzontmp
0
var a: array[0..9] of integer;
    i,n,k: integer;
    pr: string;
begin
   pr:='нет';
   for i:=0 to 9 do a[i]:=0;
   write('число: ');  readln(n);
   repeat
     k:=n mod 10;
     a[k]:=a[k]+1;
     if a[k]>1 then
     begin
       pr:='есть';
       break;
     end;  
     n:=n div 10;
   until n=0;
   writeln(pr);
end.

ввод - вывод

число: 122456
есть

число: 12546
нет






Новые вопросы