Информатика, вопрос задал abrahmanovimrick , 2 года назад

напишите программу которая меняет местами две соседних элемента списка (а[0] и а[1],а[3]... и т.д.). Если количество элементов нечётное,то последнее число должно оставаться на месте

питон помогите​

Ответы на вопрос

Ответил ebatzmyx
9

Ответ:

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   a[i - 1], a[i] = a[i], a[i - 1]

print(' '.join([str(i) for i in a])

Объяснение:

Новые вопросы