Информатика, вопрос задал mrpazitiv123 , 6 лет назад

Напишите программу, которая используя цикл while отображает на экране числа от 10 до 0. Затем перепишите программу с использованием цикла for.​

Ответы на вопрос

Ответил YKR4
0

Ответ:

# с помощью while

i = 10

while i >= 0:

   print(i)

   i -= 1 # эквивалент i = i-1

# с помощью for

for i in reversed(range(11)):

   print(i)

Объяснение:

С циклом while все просто. задаю i как начало, цикл будет работать до тех пор, пока i будет больше или равна 0.
С циклом for сложнее, но тоже легко. я просто перебираю все значения в диапазоне 10(11, потому что последнее значение не учитывается и надо ставить на один больше). Тк надо вывести их в обратной последовательности использую метод reversed(), который разворачивает диапазон c 0-10 на 10-0.

Новые вопросы