Информатика, вопрос задал mrpazitiv123 , 6 лет назад

Напишите программу, которая использует цикл for для суммирования чисел от 50 до 100. Затем перепишите программу с использованием цикла while.​

Ответы на вопрос

Ответил YKR4
0

Ответ:

# с циклом for

result = 50

for i in range(50, 101):

   result += i        # эквивалент result = result + i

print(result)

# с циклом while

result = 50

addict = 50

i = 50

while i <= 100:

   result += addict   # эквивалент result = result + addict

   addict += 1        # эквивалент addict = addict + 1

   i += 1             # эквивалент i = i + 1

print(result)

Объяснение:

Новые вопросы