Информатика, вопрос задал alihanbi25 , 7 лет назад

напишите программу , которая генерирует N случайных положительных чисел в диапазоне от 1 до Z и находит из сумму , используйте цикл со счётчиком . Необходимо выводить промежуточные результаты сумм.
(помогите пожалуйста)​


aaaaaaaaaaaaaaabaa: какой язык

Ответы на вопрос

Ответил AlenaLisa74
1

Random ran = new Random();

int N = Console.ReadLine();

int Z = Console.ReadLine();

int[] arr = new arr[N];

int sum =0;

for(int i =0; i<= arr.Length; i++) {

arr[i] = ran.Next(1, Z);

sum+=arr[i];

Console.WriteLine(sum);

}


alihanbi25: это Пейтон?
AlenaLisa74: c#
Ответил vimmortal2
1

Программа:

Python:

from random import uniform

N = int(input('N = '))

Z = float(input('Z = '))

s = 0

for i in range(1, N):

   s += uniform(1, Z)

   print(s)

Новые вопросы