Информатика, вопрос задал desk385 , 1 год назад

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое. Решить с помощь циклов while и for(на питоне). Даю 30 баллов за решение

Ответы на вопрос

Ответил dsmyrnov1997
1

Ответ:

Объяснение:

import random

# Инициализация переменных

sum = 0

count = 0

# Генерация 10 случайных чисел

for i in range(10):

   num = random.randint(1, 20)

   print(num)

   sum += num

   count += 1

# Вычисление среднего арифметического

average = sum / count

# Вывод результата на экран

print("Среднее арифметическое:", average)








import random

# Инициализация переменных

sum = 0

count = 0

# Генерация 10 случайных чисел

while count < 10:

   num = random.randint(1, 20)

   print(num)

   sum += num

   count += 1

# Вычисление среднего арифметического

average = sum / count

# Вывод результата на экран

print("Среднее арифметическое:", average)

Новые вопросы