Информатика, вопрос задал CatPsih , 6 лет назад

напишите программу, которая формирует строку из 10 символов. Под четными индексами должны быть случайные буквы, под нечетными - цифры. Подсказка: для получения случайной буквы можно создать строку с алфавитом и воспользоваться функцией choice из библиотеки random
Пример результата:
ф1п6ы7м5с8
и4р8п2в6ь5
е9м0ц9м3г1​

Ответы на вопрос

Ответил LuciFear45
2

Ответ:

import random

letters = 10

alf = 'абвгдеёжзийклмнопрстуфхцчшщъыьэюя'

string = ''

for i in range(letters):

   if i % 2 == 0:

       string += random.choice(alf)

   else:

       string += str(random.randrange(10))

print(string)

Если есть вопросы, пиши


CatPsih: спасибо большое
Новые вопросы