Информатика, вопрос задал shagapova14aisily , 1 год назад

Напишите программу, которая это сделает. Формат ввода Вводится количество чисел, затем сами числа. Формат вывода Выведите сначала тоскливые числа: Тоска ... <тоскливые числа через точку без повторений> Затем радостные: Радость! <радостные числа через восклицательный знак без повторений> Порядок вывода чисел в группе не важен. В конце строки может быть разделитель


slonce70: А как определить тоскливые числа и радостные?))Ужас чего учат в школе))Лучше бы делали какие то толковые програмки)
shagapova14aisily: на питона
shagapova14aisily: – Сэмюэль, что с тобой такое?
– Иногда мне становится так тоскливо, что я хочу сбежать в лес и жить с троллями.
– Это не поможет тебе чувствовать себя лучше. Каким бы прекрасным ни был лес сейчас.
Это была правда. Куда бы Сэмюэль ни убежал, ему в любом случае пришлось бы взять себя с собой.

Если принять, что тоска выражается нечетными числами, кратными 7, а радость – кратными 4, то можно отделить одно от другого. Напишите программу, которая это сделает.

Ответы на вопрос

Ответил Аноним
1

Ответ:

def separate_numbers(numbers):

 # Create empty lists for longing and joyful numbers

 longing_numbers = []

 joyful_numbers = []

 

 # Iterate over the input numbers

 for num in numbers:

   # Check if the number is negative or positive

   if num < 0:

     # If the number is negative, add it to the list of longing numbers

     # if it is not already in the list

     if num not in longing_numbers:

       longing_numbers.append(num)

   else:

     # If the number is positive, add it to the list of joyful numbers

     # if it is not already in the list

     if num not in joyful_numbers:

       joyful_numbers.append(num)

 

 # Sort the longing and joyful numbers lists in ascending order

 longing_numbers.sort()

 joyful_numbers.sort()

 

 # Print the longing numbers

 print("Longing:", end=" ")

 for num in longing_numbers:

   print(num, end=", ")

 print(".")

 

 # Print the joyful numbers

 print("Joyful:", end=" ")

 for num in joyful_numbers:

   print(num, end=", ")

 print("!")

 

# Test the separate_numbers function

numbers = [3, -1, 5, 7, -2, 8, 0, -3, -1, 7]

separate_numbers(numbers)


slonce70: так зачем ты кидаешь на английском даже не откоректировав!?))ты хоть раз на Пайтоне писал или чисто шаблонки кидаешЬ?))
slonce70: Ну так ты использовал шаблон через сайт)Сам не писав код - читай правила сайта)
Новые вопросы