Информатика, вопрос задал AnyaFOX9 , 8 лет назад

Напишите программу,которая для заданной последовательности натуральных чисел подсчитывает сумму входящих в неё трехзначных чисел,которые делятся на 7.Программа получает на вход кол-во чисел в прследовательности, а затем сами числа.Кол-во чисел не превышает 1000.Введенные числа не превышают 30 000.Программа должна вести одно число-сумму трехзначных чисел,находящихся в заданной последовательности натуральных чисел.

Ответы на вопрос

Ответил hhh54
0
Program hhh54;
var n,x,i,s: longint;
begin
  s:=0;
  read (n);
  for i:=1 to n do;
    begin
      read (x);
      if (x > 99) and (x < 1000) and (x mod 7 = 0) then s:=s+x;
    end;
  write (s);
end.
Ответил AnyaFOX9
0
Что значит x
Ответил hhh54
0
x - переменная
Ответил AnyaFOX9
0
Точно спасибо огромное
Новые вопросы