Напишите программу, которая для заданного целого числа определяет:
а) является ли число четным;
б) оканчивается ли оно цифрой 5.
Для решения задачи вспомните операцию mod (остаток от деления) и составьте логические выражения для ответа на вопросы задачи.
prokill79:
На самом деле, если всё же хочешь программистом стать сделай сам(а). Я всё понимаю паскаль не тот язык чтобы пыжится, но всё же.
Ответы на вопрос
Ответил prokill79
2
Ответ:Ох уж и не думал что вернусь в этот язык
Объяснение:
program название;
var a;
Begin
Writeln ("Введите число:");
Readln(a);
if (a mod 2 <> 1) then Write("Число нечетно");
else write ("Число чётное");
if (a mod 5 <> 5 and a mod 10 <> 5) then write ("Число не оканчивается на 5")
else Write ("Число оканчивается на 5");
end.
Новые вопросы