Информатика, вопрос задал gdxdfdfsdf , 2 года назад

Напишите программу, которая бы «подбрасывала» условную монету 100 раз и сообщала, сколько раз выпал орел, а сколько — решка
python

Ответы на вопрос

Ответил nevereas3
3

Ответ:

import numpy as np

def coin_toss():

   return np.random.choice(['Heads', 'Tails'])

toss_count = 100  # Кол-во "подбрасываний"

results = {

   'Heads': 0,

   'Tails': 0

}

for i in range(toss_count):

   results[coin_toss()] += 1

print(results)

Объяснение:

В целом, вместо numpy.random.choice() можно использовать непосредственно библиотеку random:

import random as rnd

def coin_toss():

   return rnd.choice(['Heads', 'Tails'])

toss_count = 100  # Кол-во "подбрасываний"

results = {

   'Heads': 0,

   'Tails': 0

}

for i in range(toss_count):

   results[coin_toss()] += 1

print(results)

Новые вопросы