Информатика, вопрос задал lynawwrxx , 1 год назад

напишите программу которая будет выводить перевод из одной величины в другую к примеру, если вести 1 версту то выводить на экран сажени

Ответы на вопрос

Ответил Famouse
0

Ответ:

CONVERSION_TABLE = {

   "верста": 1066.8,

   "сажень": 2.1336,

   # добавьте сюда другие единицы измерения и их коэффициенты конверсии

}

value = float(input("Введите значение: "))

unit = input("Введите единицу измерения: ")

if unit in CONVERSION_TABLE:

   for other_unit, conversion_factor in CONVERSION_TABLE.items():

       if other_unit != unit:

           converted_value = value * (CONVERSION_TABLE[unit] / conversion_factor)

           print(f"{value} {unit} равно {converted_value} {other_unit}")

else:

   print("Ошибка: неверная единица измерения.")

Объяснение:

Как это работает: программа запрашивает у пользователя значение и единицу измерения, которую он хочет конвертировать. Затем она проверяет, есть ли такая единица измерения в словаре CONVERSION_TABLE. Если есть, программа перебирает все другие единицы измерения из словаря и выводит их конвертированные значения. Если же указанной единицы измерения нет в словаре, программа выводит ошибку.

Ответил ugurabbasov65
0

```CONVERSIONS = {

   "верста": 1066.8,

   "сажень": 2.1336,

   "аршин": 0.7112,

}

def convert_distance(distance, from_unit, to_unit):

   meters = distance * CONVERSIONS[from_unit]

   result = meters / CONVERSIONS[to_unit]

   return result

# Пример использования функции для преобразования 1 версты в сажени

distance = 1

from_unit = "верста"

to_unit = "сажень"

result = convert_distance(distance, from_unit, to_unit)

# Выводим результат

print(f"{distance} {from_unit} = {result} {to_unit}")```

Эта программа создает словарь CONVERSIONS, который содержит коэффициенты преобразования для трех единиц измерения длины: версты, сажени и аршины. Затем она определяет функцию convert_distance, которая принимает расстояние, единицу измерения источника и единицу измерения назначения, а затем возвращает преобразованное расстояние в единицах измерения назначения. Наконец, пример использования функции преобразует 1 версту в сажени и выводит результат на экран.

Новые вопросы