напишите программу которая будет подсвечивать врагов на языке c++
Ответы на вопрос
Чтобы написать программу, которая будет подсвечивать врагов на языке C++, вам может понадобиться следующий код:
#include <iostream>
#include <algorithm>
#include <vector>
struct Enemy
{
int x;
int y;
int health;
};
void highlightEnemies(std::vector<Enemy> enemies)
{
for (Enemy enemy : enemies)
{
if (enemy.health > 0)
{
std::cout << "Enemy at position (" << enemy.x << ", " << enemy.y << ") is highlighted!" << std::endl;
}
}
}
int main()
{
std::vector<Enemy> enemies;
enemies.push_back({1, 2, 100});
enemies.push_back({3, 4, 50});
enemies.push_back({5, 6, 0});
highlightEnemies(enemies);
return 0;
}
В этом коде определена структура Enemy, содержащая поля для координат х и у, а также для здоровья врага. Затем определена функция highlightEnemies, которая принимает вектор врагов и выводит на экран сообщение о том, что враг подсвечен, если у него осталось больше нуля здоровья. В функции main создается вектор врагов, а затем вызывается функция highlightEnemies, чтобы подсветить врагов.