Информатика, вопрос задал millkamm , 7 лет назад

Напишите программу которая будет искать в массиве два числа и считать их произведения

Ответы на вопрос

Ответил asdfasdfsdfqwevcza
0

var  

a: array[1..100] of integer;  

n, i: byte;  

sum, p: integer;

begin  

Randomize;  

readln(n);  

sum:=0; p:=1;  

for i:=1 to n do    

begin      

a[i]:=Random(101)-50;      

write(a[i]:4);      

sum:=sum+a[i];      

p:=p*a[i];    

end;  

writeln;  

writeln('Сумма = ', sum:5);  

writeln('Произведение = ', p:5);  

sum:=0; p:=1;  

writeln('-------');  

writeln('2. С клавиатуры');  

for i:=1 to n do    

begin    

write('Элемент ', i, ' = ');    

readln(a[i]);    

sum:=sum+a[i];    

p:=p*a[i];    

end;  

writeln('Сумма = ', sum:5);  

writeln('Произведение = ', p:5);

end.


Подробнее - на Znanija.com - https://znanija.com/task/5106240#readmore

Новые вопросы