Информатика, вопрос задал angelinapotapina05 , 7 лет назад

Напишите программу и составьте блок схему к следующей задаче: с клавиатуры вводится произвольное четырёх значное целое число. найдите произведения цифр числа и разность второй и третьей цифр этого числа

Ответы на вопрос

Ответил dimaqlazov
0

Ответ:var n,s:integer;

begin

write('n = ');

readln(n);

n:=abs(n);s:=0;

while n>0 do begin s:=s+n mod 10;

n:=n div 10;

end;

writeln('s = ',s);

end.

Пример:

n = -62845

s = 25

Объяснение:

Новые вопросы