Информатика, вопрос задал timsso , 9 лет назад

напишите программу. Группа студентов сдает экзамен. оценки формируются случайным образом от 2 до 5. Напечатать кол-во полученых двок,трок,четверок,пятерок

Ответы на вопрос

Ответил cccc1808
0
pascal


const  n = 10; //Кол-во студентов
//можно сделать с вводом с клавиатуры
    var  i,a : integer; 
 o : array[2..5] of integer; 
     begin 
randomize; 
 for i :=2 to  5 do 
  o[i] := 0;   
 
for i := 1 to N do 
 begin 
   a := 2 + random(4); 
   o[a] := o[a] +1; 
  end; 
 for i := 2 to 5 do 
  writeln (i,'=',o[i]); 
 end.
Новые вопросы