Напишите программу формирования и вывода двумерного массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен
сумме двух предыдущих элементов. Два первых элемента задайте с клавиатуры.
Ответы на вопрос
Ответил kavko903
0
i, j: integer;
a: array [1..100, 1..100] of integer;
begin
readln(a[1][1], a[1][2]);
for i := 3 to 30 do
a[1][i] := a[1][i - 1] + a[1][i -2];
for i := 2 to 30 do
for j := 1 to 30 do
begin
if (j > 2) then
a[i][j] := a[i][j - 1] + a[i][j - 2]
else
if (j = 2) then
a[i][j] := a[i][1] + a[i - 1][30]
else
a[i][j] := a[i - 1][30] + a[i - 1][29];
end;
for i := 1 to 30 do
begin
for j := 1 to 30 do
write(a[i][j],' ')
writeln;
end;
end.
Вот, сорри если что пишу без компилятора
a: array [1..100, 1..100] of integer;
begin
readln(a[1][1], a[1][2]);
for i := 3 to 30 do
a[1][i] := a[1][i - 1] + a[1][i -2];
for i := 2 to 30 do
for j := 1 to 30 do
begin
if (j > 2) then
a[i][j] := a[i][j - 1] + a[i][j - 2]
else
if (j = 2) then
a[i][j] := a[i][1] + a[i - 1][30]
else
a[i][j] := a[i - 1][30] + a[i - 1][29];
end;
for i := 1 to 30 do
begin
for j := 1 to 30 do
write(a[i][j],' ')
writeln;
end;
end.
Вот, сорри если что пишу без компилятора
Новые вопросы