напишите программу для записи четырехзначного числа в обратном порядке.
Например:
2451-->1542
Паскаль.
Ответы на вопрос
Ответил srzontmp
0
var n,m: integer;
begin
write('n = '); readln(n);
m:=0;
repeat
m:=m*10+(n mod 10);
n:=n div 10;
until n=0;
writeln(m);
end.
n = 2456
6542
begin
write('n = '); readln(n);
m:=0;
repeat
m:=m*10+(n mod 10);
n:=n div 10;
until n=0;
writeln(m);
end.
n = 2456
6542
Ответил AndreyNikitin7
0
ты просто переписал из другого сайта
Ответил srzontmp
0
Во первых, это не прилично, "тыкать", во вторых, я Вам могу привести еще три варианта решения этой задачи, если Вы в этом разбираетесь. Например, такое writeln(ReadString.Reverse.JoinIntoString(''));
Ответил srzontmp
0
Или, может быть, Вы хотите "изобрести" велосипед?
Ответил AndreyNikitin7
0
нет , мне нужен другой вариант
Ответил AnonimusPro
0
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
ReadInteger().ToString().Reverse().Select(x->x.ToDigit()).Println('');
end.
//Версия 3.3, сборка 1611
begin
ReadInteger().ToString().Reverse().Select(x->x.ToDigit()).Println('');
end.
Ответил AndreyNikitin7
0
Слишком сложно 0_0
Новые вопросы
Українська мова,
2 года назад
Физика,
2 года назад
Математика,
8 лет назад
Физика,
8 лет назад
Математика,
9 лет назад
Математика,
9 лет назад