Информатика, вопрос задал suuui35u , 1 год назад

Напишите программу для вычисления суммы S = 11 + 13 + 15 +... + 49.​

Ответы на вопрос

Ответил likonarem
2

Ответ:

sum = 0

for i in range(11, 50, 2):

   sum += i

print("Сума:", sum)

Объяснение:

Этот код сначала создает переменную sum и присваивает ей значение 0. Далее с помощью цикла for переменная i пробегает значение от 11 до 49 с шагом 2, что соответствует нечетным числам в заданном диапазоне.

На каждой итерации цикла к переменной sum добавляется текущее значение i. На последнем шаге цикла переменная sum будет содержать сумму всех нечетных чисел от 11 до 49.

Наконец, с помощью функции print(), на экран выводится значение суммы в формате "Сумма: <значение суммы>".

Новые вопросы