Напишите программу для вычисления суммы положительных элементов массива целых чисел А(n)
Ответы на вопрос
Ответил shoshin142
0
Готово, даже удалось избежать создания самого массива)
Приложения:
Ответил shoshin142
0
Вот код, на всякий случай:
Ответил shoshin142
0
Program Summa;
var
n, i, a, s: integer;
Begin
//Ввод длины массива
write('Кол-во элементов в массиве -> ');
readln(n);
//Считываем вводимые элементы и сразу проверяем их на положительность
s := 0; i := 0;
for i := 1 to n do
begin
write('A(', i, ') = ');
readln(a);
if (a > 0) then
s := s + a;
end;
//Вывод ответа
write('Сумма положительных элементов массива: ', s, '.');
End.
var
n, i, a, s: integer;
Begin
//Ввод длины массива
write('Кол-во элементов в массиве -> ');
readln(n);
//Считываем вводимые элементы и сразу проверяем их на положительность
s := 0; i := 0;
for i := 1 to n do
begin
write('A(', i, ') = ');
readln(a);
if (a > 0) then
s := s + a;
end;
//Вывод ответа
write('Сумма положительных элементов массива: ', s, '.');
End.
Новые вопросы
Українська мова,
2 года назад
Українська мова,
2 года назад
Математика,
8 лет назад
Математика,
9 лет назад