Информатика, вопрос задал PomogiteSDzpiiiizzz , 2 года назад

Напишите программу для самоконтроля навыков устного счёта: пользователь вводит 6 целых чисел, после чего программа должна вывести их произведение. Чтобы перемножать числа было не слишком легко, нули не учитывайте. Гарантируется, что не все введённые числа — нули. JAVA

Ответы на вопрос

Ответил pinguinbird
1

import java.util.Scanner;

import java.util.ArrayList;

public class multi {

   public static void main(String[] args) {

       int counter = 0;

       ArrayList<Integer> arr = new ArrayList<>();

       Scanner scanner = new Scanner(System.in);

       for (int i = 1; i<=6; i++) {

           while (true) {

               System.out.print("Введите " + i + "-е значение: ");

               int v = Integer.parseInt(scanner.nextLine());

               

               if (v == 0) counter++;

               else counter = 0;

               if (i == 6 && counter >= 6) {

                   System.out.println("Все значения не могут быть равны 0!");

                   continue;

               }

               

               arr.add(v);

               break;

           }

       }

       System.out.println(arr);

       System.out.println(multiply(arr));

   }

   public static Integer multiply(ArrayList<Integer> arr) {

       int v = 0;

       for (int i : arr) {

           if (i != 0) {

               if (v == 0) v = i;

               else v *= i;

           }

       }

       return v;

   }

}

Новые вопросы