Напишите программу для решения задачи. С2.Даны целые числа a,b,с.Если а≤b≤c,то все числа замените квадратами,если а>b>c,то каждое число замените наибольшим из них,в противном случае смените знак каждого числа. С2.По номеру месяца выдайте квартал,которому он принадлежит.
Ответы на вопрос
Ответил bankbb
0
var a,b,c:integer;
begin
readln(a,b,c);
if (a<=b) and (b<=c) then
begin
a:=a*a;
b:=b*b;
c:=c*c;
end
else if (a>b) and (b>c) then
begin
if a<b then a:=b;
if a<c then a:=c;
b:=a; c:=a;
end
else
begin
a:=a*(-1);
b:=b*(-1);
c:=c*(-1)
end;
writeln(a:4, b:4, c:4);
end.
begin
readln(a,b,c);
if (a<=b) and (b<=c) then
begin
a:=a*a;
b:=b*b;
c:=c*c;
end
else if (a>b) and (b>c) then
begin
if a<b then a:=b;
if a<c then a:=c;
b:=a; c:=a;
end
else
begin
a:=a*(-1);
b:=b*(-1);
c:=c*(-1)
end;
writeln(a:4, b:4, c:4);
end.
Ответил bankbb
0
var a,b,c:integer;
begin
readln(a);
if (a>=1)and (a<=3) then writeln('1 квартал');
if (a>=4)and (a<=6) then writeln('2 квартал');
if (a>=7)and (a<=9) then writeln('3 квартал');
if (a>=10)and (a<=12) then writeln('4 квартал');
end.
begin
readln(a);
if (a>=1)and (a<=3) then writeln('1 квартал');
if (a>=4)and (a<=6) then writeln('2 квартал');
if (a>=7)and (a<=9) then writeln('3 квартал');
if (a>=10)and (a<=12) then writeln('4 квартал');
end.
Новые вопросы
Математика,
2 года назад
Русский язык,
2 года назад
Алгебра,
10 лет назад
Алгебра,
10 лет назад
Физика,
10 лет назад