Информатика, вопрос задал dikoviczkim96 , 7 лет назад

Напишите программу для решения задач пользуйтесь операции div и mod дам 24 бала

1.Задано двузначное число. Найдите средняя арифметическая цифр числа

2.Задано двузначное число. Найдите разность между количеством десятков и единиц

3. Дана масса в граммах. Переведите её в килограммы и граммы

4. площадь участка изменяется в арах. Найдите количество полных км в квадрате

Ответы на вопрос

Ответил Hdj1
0
1)var
n:Integer;
a:array [1..10] of Integer;
begin
Read(n);
a[1]:=n mod 10;
n:=n div 10;
a[2]:=n mod 10;
Write((a[1]+a[2])/2);
end.
2) var
n:Integer;
a:array [1..10] of Integer;
begin
Read(n);
a[1]:=n mod 10;
n:=n div 10;
a[2]:=n mod 10;
Write(a[2]-a[1]);
end.
3) var
n,m:Integer;
begin
Read(n);
m:=n div 1000;
Write(m,'кг',' ',n-m*1000,'г' );
end.
4)var
n,m:Integer;
begin
Read(n);
m:=n div 10000;
Write(m,'километров квадратных');
end.

Новые вопросы