напишите программу для решения задач используя div и mod
1.задано двухзначное число найдите среднее арифметическое цифр числа
2.задано двухзначное число найдите разность между количеством десятков и единиц
4.площадь участка измеряется в арах найдите количество полных км²
*4.для старорусской системы весов известны следующие соотношения:
1 берковец=10 пудов=400 фунтов=38400 золотников
напиши программу которая переводит массу заданную в золотниках в фунты пуды и берковцы
Ответы на вопрос
Ответил contrlc
0
Ответ в файлах ниже:
VVVVVVVVVVVVVVVV
VVVVVVVVVVVVVVVV
Приложения:
Ответил Аноним
0
большое спасибо
Ответил Аноним
0
ты мне сильно помог
Ответил Аноним
0
В последней задаче понадобятся переводные коэффициенты.
1 берковец=10 пудов=400 фунтов=38400 золотников.
Отсюда:
1 фунт = 38400/400 = 96 золотников
1 пуд = 400/10 = 40 фунтов
1 берковец = 10 пудов
№1
var
n:integer;
begin
Write('Введите двухзначное число: '); Read(n);
n:=Abs(n); { убираем минус, если он есть }
Writeln('Среднее арифметическое цифр числа: ',
(n div 10 + n mod 10)/2)
end.
Пример
Введите двухзначное число: 43
Среднее арифметическое цифр числа: 3.5
№2
var
n:integer;
begin
Write('Введите двухзначное число: '); Read(n);
n:=Abs(n); { убираем минус, если он есть }
Writeln('Разность количества десятков и единиц равна ',n div 10 - n mod 10)
end.
Пример
Введите двухзначное число: 38
Разность количества десятков и единиц равна -5
№3
var
a:real;
begin
Write('Площадь, ар: '); Read(a);
Writeln('Полных кв.км: ',Trunc(a/10000))
end.
Пример
Площадь, ар: 252123234
Полных кв.км: 25212
№4
const
f=96; { фунт }
p=40; { пуд }
b=10; { берковец }
var
z:longint;
kb,kp,kf:integer;
begin
Write('Введите вес в золотниках: '); Read(z);
kf:=z div 96;
z:=z mod 96;
kp:=kf div 40;
kf:=kf mod 40;
kb:=kp div 10;
kp:=kp mod 10;
Writeln('Это составит ',kb,' берковцев, ',kp,' пудов, ',
kf,' фунтов, ',z,' золотников')
end.
Пример
Введите вес в золотниках: 374252
Это составит 9 берковцев, 7 пудов, 18 фунтов, 44 золотников
1 берковец=10 пудов=400 фунтов=38400 золотников.
Отсюда:
1 фунт = 38400/400 = 96 золотников
1 пуд = 400/10 = 40 фунтов
1 берковец = 10 пудов
№1
var
n:integer;
begin
Write('Введите двухзначное число: '); Read(n);
n:=Abs(n); { убираем минус, если он есть }
Writeln('Среднее арифметическое цифр числа: ',
(n div 10 + n mod 10)/2)
end.
Пример
Введите двухзначное число: 43
Среднее арифметическое цифр числа: 3.5
№2
var
n:integer;
begin
Write('Введите двухзначное число: '); Read(n);
n:=Abs(n); { убираем минус, если он есть }
Writeln('Разность количества десятков и единиц равна ',n div 10 - n mod 10)
end.
Пример
Введите двухзначное число: 38
Разность количества десятков и единиц равна -5
№3
var
a:real;
begin
Write('Площадь, ар: '); Read(a);
Writeln('Полных кв.км: ',Trunc(a/10000))
end.
Пример
Площадь, ар: 252123234
Полных кв.км: 25212
№4
const
f=96; { фунт }
p=40; { пуд }
b=10; { берковец }
var
z:longint;
kb,kp,kf:integer;
begin
Write('Введите вес в золотниках: '); Read(z);
kf:=z div 96;
z:=z mod 96;
kp:=kf div 40;
kf:=kf mod 40;
kb:=kp div 10;
kp:=kp mod 10;
Writeln('Это составит ',kb,' берковцев, ',kp,' пудов, ',
kf,' фунтов, ',z,' золотников')
end.
Пример
Введите вес в золотниках: 374252
Это составит 9 берковцев, 7 пудов, 18 фунтов, 44 золотников
Приложения:
Ответил Mashagrit
0
Большое огромное спасибо !
Ответил Mashagrit
0
Подскажите пожалуйста, что вы приняли за kf, kp,kb?
Новые вопросы
Алгебра,
2 года назад
Алгебра,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад