Информатика, вопрос задал SpitefulSpamer , 1 год назад

Напишите программу для решения квадратного уравнения (PascalABC.NET)

Ответы на вопрос

Ответил AwolGame
1

Ответ:

program squart;

var

a,b,c,D,x1,x2:real;

begin

write('Введите множитель стоящий перед X^2 = ');

 readln(a);

 write('Введите множитель стоящий перед X^1 = ');

 readln(b);

 write('Введите множитель стоящий перед X^0 = ');

 readln(c);

 

D := sqr(b)-4*(a*c);

writeln('Дискриминант равен: ',D);

x1:=(-b+sqrt(D))/(2*a);  

x2:=(-b-sqrt(D))/(2*a);

writeln('Корни уравнения:');

writeln('X1= ',x1);

writeln('X2= ',x2);

 

end.

Объяснение:

Пример уравнения: x^2-3x-18=0

его решение в программе

Введите множитель стоящий перед X^2 = 1

Введите множитель стоящий перед X^1 = -3

Введите множитель стоящий перед X^0 = -18

Дискриминант равен: 81

Корни уравнения:

X1= 6

X2= -3

Новые вопросы