Информатика, вопрос задал binamaksimchuk , 7 лет назад

Напишите программу для решения циклической задачи
k=(sin(1+1)*sin(1+2)*sin(1+3)*sin(1+4)...*sin(1+5)...+n)

Ответы на вопрос

Ответил KungFuryP
0

Ответ:

#include <iostream>

using namespace std;

int fib (int position);

int main()

{

int answer,position;

cout<<"Which position(k) ?";

cin >> position;

cout << "n";

answer= fib(position);

cout <<answer<< " (k) is the position";

cout <<position << "Fibonachi number.n";

return 0;

}

int fib(int n)

{

int minusTwo=1, minusOne=1,answer=2;

 if (n<3)

  return 1;

for (n-=3;n;n--)

{

 minusTwo=minusOne;

 minusOne=answer;

 answer=minusOne + minusTwo;

}

return answer;

}

Объяснение:

Наскільки я зрозумів це задача на визначення значення порядкового номера ряду Фібоначчі ,тому ось вихідний код на C++

Новые вопросы