Информатика, вопрос задал Soffi7bayard , 7 лет назад

Напишите программу для получения квадратной матрицы порядка n* n.

Ответы на вопрос

Ответил superman48720
0

Ответ:

#include <iostream>

#include <ctime>

int N = NULL;

int main() {

srand((unsigned int)time(NULL));

std::cout << "Enter the N: ";

std::cin >> N;

int** matrix = new int*[N];

for (int i = 0; i < N; i++) {

 matrix[i] = new int[N];

}

for (int i = 0; i < N; i++) {

 for (int j = 0; j < N; j++) {

  matrix[i][j] = rand() % 100;

 }

}

for (int i = 0; i < N; i++) {

 for (int j = 0; j < N; j++) {

  std::cout << matrix[i][j] << " ";

 }

 std::cout << std::endl;

}

for (int i = 0; i < N; i++) {

 delete[] matrix[i];

}

delete[] matrix;

return 0;

}

Объяснение:

Данные матрицы — случайные числа

Память на массивы выделяется динамически, затем чистится.

Новые вопросы