Напишите программу для поиска наибольшего общего делителя двух чисел.
Формат ввода
два целых числа
Формат вывода
целое число
Пример
Ввод Вывод
6
15
3
Ответы на вопрос
Ответил lozromanik
0
Відповідь:
#include <iostream>
using namespace std;
int divev(int a,int b){
while(a*b!=0){
a>b?a%=b:b%=a;
}
return a+b;}
int main()
{int a,b;
cin>>a>>b;
cout<<divev(a,b);
return 0;
}
Новые вопросы
Другие предметы,
2 года назад
Химия,
2 года назад
Українська мова,
7 лет назад
Биология,
7 лет назад
Геометрия,
8 лет назад