напишите программу для подсчёта суммы и произведения вводимого числа
Леганда555:
суммы и произведения чего?
Ответы на вопрос
Ответил Леганда555
1
var
sum, comp: Int64;
i: Word;
s: string;
begin
Read (s);
sum := 0;
comp := Ord (s[1]) - 48;
for i := 1 to Length (s) do
sum := sum + Ord (s[i]) - 48;
for i := 2 to Length (s) do
comp := comp * Ord (s[i]) - 48;
WriteLn ('Сумма цифр в числе ', s, ' = ', sum);
Write ('Произведение цифр в числе ', s, ' = ', comp);
end.
Приложения:

Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Алгебра,
2 года назад
Английский язык,
2 года назад
Музыка,
8 лет назад