Информатика, вопрос задал Vikysia97 , 10 лет назад

напишите программу для паскаля.

условие: обменять значения двух переменных, используя третью(буферную) переменную

Ответы на вопрос

Ответил Tlalok
0

var

  a, b, buf:real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  buf := a;

  a := b;

  b := buf;

  writeln('a = ', a);

  writeln('b = ', b);

end.

 

 

// без буферной переменной

var

  a, b:real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  a := a + b;

  b := a - b;

  a := a - b;

  writeln('a = ', a);

  writeln('b = ', b);

end.

 

Новые вопросы