Напишите программу для PascalABC срочно!
Дано 5-значное число. Если оно палиндром, то вывести 0, если нет-1
Ответы на вопрос
Ответил Аноним
0
Var
i: string;
Begin
Writeln('Введите число');
Readln(i);
if ((i[1]=i[5]) and (i[2]=i[4])) then writeln('0') else writeln('1');
End.
i: string;
Begin
Writeln('Введите число');
Readln(i);
if ((i[1]=i[5]) and (i[2]=i[4])) then writeln('0') else writeln('1');
End.
Ответил Аноним
0
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
begin
var s:=ReadInteger('n=').ToString;
if s=s.Inverse then Writeln(0) else Writeln(1)
end.
begin
var s:=ReadInteger('n=').ToString;
if s=s.Inverse then Writeln(0) else Writeln(1)
end.
Ответил Аноним
0
Возможно это лишнее, но предложенная программа проверяет на "палиндромность" целые числа любой допустимой разрядности, а не только пятизначные.
Новые вопросы