Информатика, вопрос задал forrostovdon , 9 лет назад

Напишите программу для определения сдачи K руб. после покупки в магазине товара: перчаток стоимостью A руб., портфеля стоимостью B руб., галстука стоимостью C руб. Исходная сумма, выделенная на покупку D руб. В случае нехватки денег сдача получится отрицательной.(A,B,C,D- вводятся с клавиатуры).

заранее очень благодарна!!

Ответы на вопрос

Ответил Dimarik708
0
var a, b, c, d : integer;
begin
writeln('Цена перчаток: ');
readln(a);
writeln('Цена портфеля: ');
readln(b);
writeln('Цена галстука: ');
readln(c);
writeln('Внесенная сумма: ');
readln(d);
writeln('Сдача: ', d-a-b-c)
end.
Ответил Dimarik708
0
Я не виноват, что этот глупый сервис знания. ком не правильно копирует текст написанный в Pascal!!!!
Ответил m0nclous
0
Если вы используете двоеточие в конце строки, то не думаю что стоило использовать функцию writeln(), мне кажется лучше бы подошла write()
Ответил Dimarik708
0
У меня стандарт.. И мне больше нравится writeln, да с таким же успехом можно использовать read вмеcто readln
Ответил Dimarik708
0
Можете не сомневаться в моей информатике!
Ответил m0nclous
0
read и readln почти ничем не отличаются визуально, а вот writeln() переводит строку
Ответил Podpletneff
0

var

a, b, c, d:real;

begin

writeln('Введите стоимость перчаток');

readln(a);

writeln('Введите стоимость портфель');

readln(b);

writeln('Введите стоимость галстука');

readln(c);

writeln('Введите сумму выделенную на покупку');

readln(d);

writeln('Сдача составляет: ', d-a-b-c);

end.

Ответил Dimarik708
0
Лол..
Ответил Podpletneff
0
Вот так Лол... Не парень если думаешь что я у тебя взял решение, то зря ты так думаешь. Можешь в профили у меня посмотреть, я прекрасно решаю задачи на паскаль. Просто в этой задачи решение НУ ОЧЕНЬ ЛИНЕЙНОЕ и вполне может совпадать.
Ответил Dimarik708
0
Да, ладно.. Верю:)
Ответил Podpletneff
0
Спасибо:) хах
Ответил Dimarik708
0
))
Новые вопросы