Напишите программу для нахождения минимальной и максимальной цифры в числе.Язык c++
mmgodunko:
число десятичное?
Ответы на вопрос
Ответил mmgodunko
0
Ответ:
#include <iostream>
#define max 100
using namespace std;
int index;
char input = 0;
int ln;
char min = '9' + 1;
char max = '0';
int nul;
int main()
{
cin >> input;
for(int j = 0; input[j] != '\0'; j++){
ln = j + 1;
}
for(int j = 0; j < ln ; j++){
if( input[j] < min){
min = input[j];
}
}
for(int j = 0; j < ln ; j++){
if (input[j] > max){
max = input[j];
}
}
cout << "max:" << max;
cout << "min:" << min;
cin >> nul;
return 0;
}
P.S.я не уверен, если у тебя не запуститься пиши
Новые вопросы
Физика,
1 год назад
Математика,
1 год назад
Математика,
1 год назад
История,
1 год назад
Математика,
7 лет назад