Информатика, вопрос задал National91818181991 , 1 год назад

Напишите программу для 9 класса. Найдите периметр треугольника по его координатам

Ответы на вопрос

Ответил Kto3ta
0

Ответ:

import math

def find_perimeter(x1, y1, x2, y2, x3, y3):

   # Вычислим расстояние между двумя точками, используя формулу расстояния

   side1 = math.sqrt((x2-x1)**2 + (y2-y1)**2)

   side2 = math.sqrt((x3-x2)**2 + (y3-y2)**2)

   side3 = math.sqrt((x1-x3)**2 + (y1-y3)**2)

   # Рассчитаем периметр, используя три стороны

   perimeter = side1 + side2 + side3

   return perimeter

x1, y1 = map(int,input().split())

x2, y2 = map(int,input().split())

x3, y3 = map(int,input().split())

print(find_perimeter(x1, y1, x2, y2, x3, y3))

Объяснение:

Программа определяет функцию find_perimeter, которая принимает координаты x и y трех точек треугольника. Затем он использует формулу расстояния для вычисления длины каждой стороны треугольника. Наконец, он складывает три стороны, чтобы найти периметр.

Новые вопросы