Информатика, вопрос задал jdg6h , 2 года назад

Напишите программу:
1. Подсчитать количество символов во фразе ФИО.
2.По вводимым словам, (два - три слова) печатается
фраза.
Например
Введите первое слово (сам)
Введите второе слово (ход)
На экране:
самоход
3. Вводится имя и ответ на вопрос. На экран выводится
предложение (если да, то одно, иначе – другое)
Например:
Как вас зовут? (Ирина)
Вы любите гулять? (Да) (Нет)
Если да - на экране:
Ирина. Давай прогуляемся в Летнем саду.
Иначе - на экране:
Ирина. Давай сходим в кино.​

Приложения:

Sulik200000: Какой язык программирования?

Ответы на вопрос

Ответил Sulik200000
1

Ответ:

using namespace std;

int main(){

   system("chcp 1251>nul");

   string firstName = " ", secondName = " ", thirdName = " ";

   cin >> firstName >> secondName >> thirdName; // Через пробел вводишь

   int count = firstName.size() + secondName.size() + thirdName.size();

   cout << "Длина ФИО: " << count << endl;

   string firstWord = "", secondWord = "";

   cout << "Введите два слова(через пробел)";

   cin >> firstWord >> secondWord;

   string Word = firstWord + "о" + secondWord;

   cout << "Слово: " << Word << endl;

   string name = "";

   cout << "Как вас зовут? ";

   cin >> name;

   cout << name + ". Вы любите гулять?(Да/Нет) ";

   string ans = "";

   cin >> ans;

   if(ans == "Да" || ans == "да"){

       cout << endl << name << ". Давай прогуляемся в Летнем саду.";

   }

   else{

       cout << endl << name << ". Давай сходим в кино.​"

   }

   system("pause>nul");

}

Это программа на C++

Новые вопросы