Информатика, вопрос задал wdfg5546gddf , 7 лет назад

НАПИШИТЕ ПОЖАЛУЙСТА ПРОГРАММЫ В ПИТОНЕ
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Программа должна вывести числа, количество чисел, кратных 7.
2.Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 7. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Программа должна вывести сумму чисел, кратных 7.

Ответы на вопрос

Ответил smartemii03jurma
3

Ответ:

a = int(input())

sum = 0

counter = 0

while a != 0:

   if a % 7 == 0:

       sum += a

       counter += 1

   a = int(input())

print('Количество чисел, кратных 7:', counter)

print('Сумма чисел, кратных 7:', sum)


wdfg5546gddf: а это для какой из задач? или к обоим подойдет?
smartemii03jurma: и для количества и для суммы. в выводе это прописывается
smartemii03jurma: sum считает сумму, а counter количество
Новые вопросы