Информатика, вопрос задал Муса134 , 1 год назад

Напишите, пожалуйста, программу сортировки подсчётом по возрастанию на Free Pascal. Входные данные берутся из текстового файла input.txt. Отсортированный массив записывается в output.txt.​

Ответы на вопрос

Ответил Indentuum
1

Значение M поменяй в соотстветсвие диапазону.

const M = 100;

var n,i,d:longint;

   a:array[-M..M] of longint;

begin

 assign(input,'input.txt'); reset(input);

 assign(output,'output.txt'); rewrite(output);

 fillchar(a,sizeof(a),0);

 read(n);

   for i:=1 to n do

   begin

   read(d);

   inc(a[d]);

   end;

 

   for i:=-M to M do

   begin

     for d:=1 to a[i] do

     write(i,' ');

   end;

 close(input);

 close(output);

end.

Новые вопросы