Информатика, вопрос задал хельгаль , 10 лет назад

Напишите пожалуйста программу с помощью Паскаля:Дана последовательность 5 9 13 17 21 25 29 33 37 41 45 49. Составьте программу для подсчета числа слагаемых сумма которых равна 324

Ответы на вопрос

Ответил KGM
0

var sum, i, s: integer;  //обыявляем необходимые переменные

//sum - сумма, i - кол-во слогаемых, s - само слогаемое


begin  //начало
  sum := 0; i := 1; s := 5;  //первое слогаемое = 5
  while (sum < 324) do  //пока сумма меньше 324
  begin
    sum := sum + s;  //к сумме прибавляем слагаемое
    s := s + 4;  //увеличиваем слогаемое
    i := i + 1;   //увеличиваем кол-во слогаемых
  end;
  writeln ('Слогаемых: ');  // выводим кол-во слогаемых
  write (i);
end.  //конец

Новые вопросы