Информатика, вопрос задал Аноним , 1 год назад

Напишите пожалуйста программу, не могу решить уже какой день...
Даю 27 баллов!!!
Вот задача:

Количество каждой буквы

По данному слову, состоящему из строчных латинских букв, посчитайте количество каждой буквы.


Входные данные


На вход подается одна строка без пробелов, состоящая не более 1000 строчных латинских букв.


Выходные данные


Выведите на каждой строке в алфавитном порядке только те символы, которые встречаются в строке. Возле каждого символа выведите сколько раз встречается данный символ.


Sample Input:

beegeek


Sample Output:

b 1

e 4

g 1

k 1

Приложения:

Ответы на вопрос

Ответил AnonimusPro
2

using System;

class Program

{

   static void Main() {

      string s=Console.ReadLine(),dic="abcdefghijklmnopqrstuvwxyz";

      int k=0;

      for(int i=0;i<dic.Length;i++)

      {

        for(int j=0;j<s.Length;j++)

          if(s[j]==dic[i])

            k++;

        if(k!=0)

        {

          Console.WriteLine(dic[i].ToString()+" "+k.ToString());

          k=0;

        }

      }

     

   }

}


Аноним: Спасибо огромное!!!!
Новые вопросы