НАПИШИТЕ НА С++ Составьте программу для вычисления длин высот треугольника, у которого длины сторон a, b, c.
Ответы на вопрос
Ответил Segrif
0
#include<iostream>
#include<cmath>
using namespace std;
int main(){
double a,b,c,p,S;
cin >> a >> b >> c;
p = (a + b + c)/2;
S = sqrt(p * (p - a) * (p - b) * (p - c)); // Формула Герона
cout << 2*S/a << "; " << 2*S/b << "; " << 2*S/c; // S = 1/2 a * h1 -> h1 = 2S / a
return 0;
}
#include<cmath>
using namespace std;
int main(){
double a,b,c,p,S;
cin >> a >> b >> c;
p = (a + b + c)/2;
S = sqrt(p * (p - a) * (p - b) * (p - c)); // Формула Герона
cout << 2*S/a << "; " << 2*S/b << "; " << 2*S/c; // S = 1/2 a * h1 -> h1 = 2S / a
return 0;
}
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Физика,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад