Напишите на паскале. Задание: Написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом
R
Ответы на вопрос
Ответил srzontmp
0
var a,b,c,r,s,p: real;
begin
write('длины сторон треугольника a,b,c через пробел: ');
readln(a,b,c);
write('радиус круга r: '); readln(r);
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
if r>=(a*b*c)/(4*s) then writeln('можно поместить')
else writeln('нельзя поместить');
end.
длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.49
нельзя поместить
длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.5
можно поместить
begin
write('длины сторон треугольника a,b,c через пробел: ');
readln(a,b,c);
write('радиус круга r: '); readln(r);
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
if r>=(a*b*c)/(4*s) then writeln('можно поместить')
else writeln('нельзя поместить');
end.
длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.49
нельзя поместить
длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.5
можно поместить
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Химия,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад