Напишите на pascal
Задача 1: Отпуск
Иван Петрович взял отпуск продолжительностью n дней. Первый день отпуска выпадает на день недели под номером d (1 — понедельник, 2 — вторник, ..., 7 — воскресенье). Иван Петрович любит ездить отдыхать на Кипр. Но вылеты на Кипр из его родного города есть только по понедельникам, а обратно — только по воскресеньям. Иван Петрович хочет понять, какое максимальное количество недель он сможет провести на Кипре в свой отпуск (день прилёта и день обратного вылета Иван Петрович считает днями, проведёнными на Кипре). Помогите ему вычислить это.
Входные данные
В первой строке входных данных записано целое число n (1 ≤ n ≤ 109) — продолжительность отпуска. Во второй строке записано целое число — d (1 ≤ d ≤ 7) — номер дня недели первого дня отпуска.
Выходные данные
Требуется вывести одно целое число — количество недель, которое Иван Петрович проведёт на Кипре.
Ответы на вопрос
Ответил vsandrey
11
Ответ:
program t1;
var
n,a,res:integer;
begin
readln(n, a);
if a > 1 then
a:=1-a+7
else
a:=0;
res:=(n-a) div 7;
write(res);
end.
Объяснение:
Приложения:
romagagarin2004:
спасибо большое, можешь помочь с задачей?как тобой с тобой связаться
Новые вопросы